Reminder: i18n strawman
cierniak at google.com
Wed May 16 12:25:05 PDT 2007
I also think that this would not be too burdensome.
On 5/16/07, Bryan Atsatt <bryan.atsatt at oracle.com> wrote:
> ListResourceBundle cannot be demoted to second-class citizen status in
> the module system (Perhaps you haven't seen my earlier response?).
> There is a solution to the split package problem, and, while it does
> change the development model slightly, I think that is in line with the
> more significant model change of moving to a module system...
> Introduce a package naming convention for resource bundles deployed as
> modules. The convention would allow ResourceBundle.getBundle() to easily
> map from the "base" name to the actual bundle package name.
> For example, if we introduce the convention that resource bundle "base"
> names are mapped such that "resources" is appended to the package name,
> then calling ResourceBundle.getBundle with:
> Would actually search for resources with the base name:
> thus sidestepping the split package issue.
> Yes, this requires developers to actually define their resources using
> this naming convention, but I don't see that as a significant burden.
> Especially when you consider the benefit of not having to package all
> translations in the primary module.
> To avoid potential package name collisions, we should consider using a
> more distinct name than simply "resources", e.g.:
> // Bryan
More information about the jsr277-eg-observer