Optional class is just a Value
pbenedict at apache.org
Wed Sep 19 08:47:09 PDT 2012
I think the Optional class could be better named. I consider it a negative
noun -- focusing on its ability to not contain a value. Really, it is
nothing more than a bean for a value (and the value might be absent). It
could have greater use than lambda so maybe it could be called something
Lacking a better suggestion myself, I thought it should be called "Value"
... and, if you refactored into an interface, you could possibly retrofit
the java.lang type wrappers to implement it too.
More information about the lambda-dev