Optional class is just a Value

Julian Hyde julianhyde at gmail.com
Wed Sep 19 10:33:20 PDT 2012

On Sep 19, 2012, at 8:47 AM, Paul Benedict <pbenedict at apache.org> wrote:

> I think the Optional class could be better named. I consider it a negative
> noun -- focusing on its ability to not contain a value.

The name made sense to me... but then I was familiar with the similar concept in Scala.


On reflection, the Scala name makes more sense. "Optional" (adjective) implies behavioral (hence usually applies to an interface) whereas "Option" (noun) implies structural.


More information about the lambda-dev mailing list