Consumers and Suppliers
jed at wesleysmith.io
Sat Apr 6 18:25:01 PDT 2013
We call it Effect, because the only possible thing a method that
returns void can do, is side-effects.
On 6 April 2013 04:36, Brian Goetz <brian.goetz at oracle.com> wrote:
>> About the choice of name of "Consumer", I seriously hate it. It has a
>> connotation that the ownership of the object is transferred, and object
>> might be dissolved. In many of my use cases, "consumer" simply sounds
>> grotesque and totally misleading. I wish the choice was Procedure instead.
>> (I'm just venting, not asking for change.)
> Yes, finding names was very hard. Suffice it to say that there was no
> name considered that *someone* didn't hate.
More information about the lambda-dev