john at milsson.nu
Tue Jan 1 16:07:01 PST 2013
For what it's worth. I think the math people got it wrong with "∘". The
other operation they call compose: "*;*" - which has applicative order -
feels more natural. So one vote for keeping compose as "*;*". Also, this is
the composition operation for statements Java programmers have been using
for years with no complaint, so why arbitrarily switch to "∘" for function
Besides even the math people revert to applicative order when modelling
function composition as a category.
On Wed, Jan 2, 2013 at 12:40 AM, Jed Wesley-Smith <jed at wesleysmith.io>wrote:
> hello lambdarians!
> Just noticed that the java.util.function.Function.compose method is
> round the wrong way (according to the common definition of function
> The current lambda definition:
> has f.compose(g) mean apply f and then apply g, whereas the usual
> (most other languages and the literature) has f ∘ g mean apply g and
> then apply f.
> The form that Function has currently is commonly known as andThen. So,
> you could rename the current method andThen and add a new compose
> method that works in the usual manner.
> * references:
More information about the lambda-dev