RFR 8016281: The SAM method should be passed to the metafactory as a MethodType not a MethodHandle
maurizio.cimadamore at oracle.com
Mon Jul 8 03:30:33 PDT 2013
On 07/07/13 19:57, Remi Forax wrote:
> On 07/07/2013 07:49 PM, Robert Field wrote:
>> Please review the fix for CR:
>> See also duplicate bug for more motivation:
>> Note this includes metafactory (JDK) and the corresponding javac
>> (langtools) changes.
> Hi Robert,
> I like this cleanup, patch is Ok for me,
> I just think that "functionalInterfaceType" is a better name than
> especially when "invokedType" is used as a name of one of the component
> of the serialized form.
More information about the lambda-dev