RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull
howard.lovatt at gmail.com
Thu Jun 20 00:24:46 PDT 2013
I would say not needed, !isNull() is sufficient. If included isNotNull() is
the better name.
On 5 May 2013 01:09, Ulf Zibis <Ulf.Zibis at cosoco.de> wrote:
> Am 04.05.2013 04:28, schrieb Mike Duigou:
> > I have updated the webrev to include incorporate the feedback I have
> > http://cr.openjdk.java.net/~mduigou/JDK-8013712/1/webrev/
> > Regarding the naming of the "nonNull" method. I originally added this
> method in 2011 but I've forgotten since then why it has the name it does.
> As best as I can determine the name is either derived from the the name
> used by Guava for the same predicate, "notNull", or the names derives from
> the name "requireNonNull" in that this method doesn't require that the
> reference be non-null. The EG hasn't been concerned that this method
> doesn't use the "is" prefix.
> Do we need nonNull/isNotNull() at all, as it's always !isNull()?
> Anyway I would prefer isNotNull().
More information about the lambda-dev