RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull
jack at moxley.co.uk
Thu Jun 20 00:36:32 PDT 2013
Really depends about whether you want the method to be bad English, or really bad English. :-). All this double negativity gets me down. What's wrong with exists() ?
Sent from my iPhone
On 20 Jun 2013, at 08:24, Howard Lovatt <howard.lovatt at gmail.com> wrote:
> I would say not needed, !isNull() is sufficient. If included isNotNull() is
> the better name.
> On 5 May 2013 01:09, Ulf Zibis <Ulf.Zibis at cosoco.de> wrote:
>> Am 04.05.2013 04:28, schrieb Mike Duigou:
>>> I have updated the webrev to include incorporate the feedback I have
>>> Regarding the naming of the "nonNull" method. I originally added this
>> method in 2011 but I've forgotten since then why it has the name it does.
>> As best as I can determine the name is either derived from the the name
>> used by Guava for the same predicate, "notNull", or the names derives from
>> the name "requireNonNull" in that this method doesn't require that the
>> reference be non-null. The EG hasn't been concerned that this method
>> doesn't use the "is" prefix.
>> Do we need nonNull/isNotNull() at all, as it's always !isNull()?
>> Anyway I would prefer isNotNull().
> -- Howard.
More information about the lambda-dev