inconsistent naming of Stream.sorted()?

Gernot Neppert mcnepp02 at
Thu May 23 07:40:05 PDT 2013


I've been testing build 90 of JDK 1.8, and I came up with this question:

Stream.sorted is the only method that uses the past participle form of the
verb that describes it.
All others, (such as filter, map, etc.) simply use the infinitive.

Was this a deliberate decision or an an oversight?

More information about the lambda-dev mailing list