Collection.toArray <was> Re: Loose ends inventory

Remi Forax forax at
Tue Jun 11 09:26:55 PDT 2013

On 06/11/2013 06:21 PM, Brian Goetz wrote:
> If we were considering this overload at the outset, we would never in 
> a zillion years consider this name, it would be just another overload 
> of toArray.  The only reason to consider it now is because of the 
> accidental reality of internal tests that would have to be changed -- 
> which test code that *no user will ever write*.  No user code will be 
> broken.  I realize there is a cost to changing the tests, but there's 
> also a cost -- one that accrues to all the users -- of choosing a 
> different name.
> Paul's point is not to let the TCK tail wag the API dog.

I agree with Paul and Brian, toArray is fine.


>>>> Why not just given another name?
>> ... like toGeneratedArray?
>> -Doug

More information about the lambda-libs-spec-experts mailing list