Collection.toArray <was> Re: Loose ends inventory

Brian Goetz brian.goetz at
Tue Jun 11 09:21:05 PDT 2013

If we were considering this overload at the outset, we would never in a 
zillion years consider this name, it would be just another overload of 
toArray.  The only reason to consider it now is because of the 
accidental reality of internal tests that would have to be changed -- 
which test code that *no user will ever write*.  No user code will be 
broken.  I realize there is a cost to changing the tests, but there's 
also a cost -- one that accrues to all the users -- of choosing a 
different name.

Paul's point is not to let the TCK tail wag the API dog.

>>> Why not just given another name?
> ... like toGeneratedArray?
> -Doug

More information about the lambda-libs-spec-observers mailing list