StreamSupport -> Streams?

Brian Goetz brian.goetz at
Thu Jun 20 14:17:51 PDT 2013

Two objections:

1.  This is not an SPI!  The SPI would be the currently-hidden XxxOp APIs.

2.  The package is already so small (and getting like 20% smaller when 
we kill CloseableStream and DelegatingStream) as to be silly to have 
another package with one file.

Sam's point, which is a good one, is that it was confusing to mix two 
audiences together in one file, but now that there's only one audience 
for this set of static methods, we can pick a less crappy name.  (Even 
though the name choice was slightly deliberately crappy, but the need to 
create contrast is much lower now that the API is so much smaller than 
it was then.)

On 6/20/2013 5:13 PM, Remi Forax wrote:
> On 06/20/2013 11:10 PM, Sam Pullara wrote:
>> I'm just not happy with StreamSupport. There are perfectly reasonable
>> methods in there for library writers. I'm sure the javadocs can make
>> it clear what their purpose is and redirect people.
>> Sam
> I don't care if the class name is Streams or StreamSupport but I think
> it should be moved from package to
> Rémi
>> On Jun 20, 2013, at 2:08 PM, Tim Peierls <tim at
>> <mailto:tim at>> wrote:
>>> On Thu, Jun 20, 2013 at 4:56 PM, Brian Goetz <brian.goetz at
>>> <mailto:brian.goetz at>> wrote:
>>>     Streams was already scheduled to be GC'ed, which would have left
>>>     only StreamSupport.
>>>     The incremental suggestion from Sam was "Now that Streams is
>>>     being GCed, can't we then rename StreamSupport to Streams, where
>>>     this stuff used to live anyway?"
>>> It might subtly push people who would otherwise happily ignore
>>> StreamSupport into thinking that these Streams methods were for
>>> general use.
>>> --tim

More information about the lambda-libs-spec-observers mailing list