Problems running Swing app with latest build?

Greg Brown greg.x.brown at
Mon Feb 13 10:06:13 PST 2012

Hi all,

I can't seem to launch the Swing Set demo with the latest build. I get the following error:

java -jar /Library/Java/Demos/JFC/SwingSet2/SwingSet2.jar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib: dlopen(/Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib, 1): Library not loaded: /usr/X11/lib/libfreetype.6.dylib
  Referenced from: /Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib
  Reason: Incompatible library version: libfontmanager.dylib requires version 14.0.0 or later, but libfreetype.6.dylib provides version 13.0.0
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(
	at java.lang.ClassLoader.loadLibrary(
	at java.lang.Runtime.loadLibrary0(
	at java.lang.System.loadLibrary(
	at sun.lwawt.macosx.LWCToolkit$
	at Method)
	at sun.lwawt.macosx.LWCToolkit.<clinit>(
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(
	at java.awt.Toolkit$
	at Method)
	at java.awt.Toolkit.getDefaultToolkit(
	at javax.swing.UIManager.getSystemLookAndFeelClassName(
	at javax.swing.UIManager$
	at Method)
	at javax.swing.UIManager.loadSwingProperties(
	at javax.swing.UIManager.initialize(
	at javax.swing.UIManager.maybeInitialize(
	at javax.swing.UIManager.getUI(
	at javax.swing.JPanel.updateUI(
	at javax.swing.JPanel.<init>(
	at javax.swing.JPanel.<init>(
	at javax.swing.JPanel.<init>(
	at SwingSet2.<init>(
	at SwingSet2.main(

I also tried a build from a few days ago and I get the same error. I did not see this problem with the build I downloaded a couple of weeks ago. 

Is this a known issue? Possibly a configuration issue on my end?


More information about the macosx-port-dev mailing list