Problems running Swing app with latest build?

Mike Swingler swingler at
Mon Feb 13 10:22:07 PST 2012

On Feb 13, 2012, at 10:06 AM, Greg Brown wrote:

> Hi all,
> I can't seem to launch the Swing Set demo with the latest build. I get the following error:
> java -jar /Library/Java/Demos/JFC/SwingSet2/SwingSet2.jar
> Exception in thread "main" java.lang.UnsatisfiedLinkError: /Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib: dlopen(/Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib, 1): Library not loaded: /usr/X11/lib/libfreetype.6.dylib
>  Referenced from: /Library/Java/JavaVirtualMachines/1.7.0u-dev.jdk/Contents/Home/jre/lib/libfontmanager.dylib
>  Reason: Incompatible library version: libfontmanager.dylib requires version 14.0.0 or later, but libfreetype.6.dylib provides version 13.0.0
> 	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
> 	at java.lang.ClassLoader.loadLibrary0(
> 	at java.lang.ClassLoader.loadLibrary(
> 	at java.lang.Runtime.loadLibrary0(
> 	at java.lang.System.loadLibrary(
> 	at sun.lwawt.macosx.LWCToolkit$
> 	at Method)
> 	at sun.lwawt.macosx.LWCToolkit.<clinit>(
> 	at java.lang.Class.forName0(Native Method)
> 	at java.lang.Class.forName(
> 	at java.awt.Toolkit$
> 	at Method)
> 	at java.awt.Toolkit.getDefaultToolkit(
> 	at javax.swing.UIManager.getSystemLookAndFeelClassName(
> 	at javax.swing.UIManager$
> 	at Method)
> 	at javax.swing.UIManager.loadSwingProperties(
> 	at javax.swing.UIManager.initialize(
> 	at javax.swing.UIManager.maybeInitialize(
> 	at javax.swing.UIManager.getUI(
> 	at javax.swing.JPanel.updateUI(
> 	at javax.swing.JPanel.<init>(
> 	at javax.swing.JPanel.<init>(
> 	at javax.swing.JPanel.<init>(
> 	at SwingSet2.<init>(
> 	at SwingSet2.main(
> I also tried a build from a few days ago and I get the same error. I did not see this problem with the build I downloaded a couple of weeks ago. 
> Is this a known issue? Possibly a configuration issue on my end?

It looks like the libfreetype version on the builder is higher than the one on your machine. Possibly built on 10.7 Lion but running on 10.6 Snow Leopard?

As a general point, the JDK 7 on the Mac should not be linking against libfreetype in the first place, because it's an X11 component, and optionally installed on Mac OS X. If there isn't a bug already to this effect, I'd be more than happy to file it.

Mike Swingler
Apple Inc.

More information about the macosx-port-dev mailing list