need ideas for how to name incremental jdk builds to be findable by /usr/libexec/java_home

Scott Kovatch scott.kovatch at
Fri Feb 24 14:24:35 PST 2012

On Feb 24, 2012, at 2:02 PM, Stephen Bannasch wrote:

> At 11:02 AM -0800 2/24/12, Scott Kovatch wrote:
>> Are you building the JDK yourself? If so you want to set
>> and then you'll see
>> Matching Java Virtual Machines (2):
>>   1.7.0_04, x86_64:	"OpenJDK 7"	/Library/Java/JavaVirtualMachines/jdk1.7.0_04.jdk/Contents/Home
> Thanks Scott, that worked:
> $ /usr/libexec/java_home -v 1.7 -V
> Matching Java Virtual Machines (2):
>    1.7.0, x86_64:	"OpenJDK 7"	~/Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home
>    1.7.0_04, x86_64:	"OpenJDK 7"	~/Library/Java/JavaVirtualMachines/1.7.0_04-2012_02_24.jdk/Contents/Home
> BUT ... the new jdk still doesn't show up running this app:
>  /Applications/Utilities/Java\
> I'm on 10.6 ... and I realize the plan is to stop supporting the 'Java Preferences' app but I am surprised that the 1.7.0_04 JDK doesn't show up.

I don't have 10.6, but 1.7.0 JVMs show up in Java Preferences in 10.7. It could be that, but I don't think so. Mike can confirm.

I thought this was because Java 7 can't be used for bundled Java apps that use JavaApplicationStub. This panel controls the order in which JVMs are scanned for a version that matches the JVMVersion in the Info.plist. But you should also be able to drag Java 7 to the top of that list so it can be used as the default Java for the command line.

-- Scott K.

More information about the macosx-port-dev mailing list