Swap should be better done native?
Ulf.Zibis at gmx.de
Fri Apr 2 15:42:11 PDT 2010
Am 02.04.2010 19:50, schrieb Ulf Zibis:
> Am 02.04.2010 16:13, schrieb Ulf Zibis:
>> Am 02.04.2010 02:04, schrieb Ulf Zibis:
>>> Am 01.04.2010 01:29, schrieb Martin Buchholz:
>>>> On Wed, Mar 31, 2010 at 16:11, Ulf Zibis<Ulf.Zibis at gmx.de> wrote:
>>>>> Not to forget java.nio.Heap-X-Buffer.java.template.
>>>> Ulf, would you like to provide a patch that deletes all uses of
>>>> java.nio.Bits.swap and replaces them with the relevant
>>>> reverseBytes methods?
>>> See attachments.
>>> - Most, but not all, i.e. Float, Double, SIZE constants were at
>>> "wrong" position. I have corrected this.
>>> - I too think, serialVersionIDs should be positioned more upper,
>>> e.g. as last of all static finals.
>>> - I'm not enough experienced in make files, and I can't run them on
>>> my Windows system, so genBuffer.sh change is incomplete.
>> - Removed superfluous casts and bloated white space.
- Use more descriptive names
Alternatively I think we would better have separate classes for
- DirectUnalignedByteBuffer (unalignedAccessible)
- DirectUnalignedByteBufferR (unalignedAccessible)
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
More information about the nio-dev