Fw: Patch for File Scanning

Ulf Zibis Ulf.Zibis at gmx.de
Mon Oct 24 01:47:39 PDT 2011

Another thought:
Is the cost for instantiation of an AcceptAllFilter object so high, that it justifies the loading of 
an additional static helper class.
Because the cost for the latter is > 0, I would prefer a simple lazy instantiation by "If (x == null)".
Please keep footprint of JDK binary low as possible.


Am 24.10.2011 10:30, schrieb Alan Bateman:
> On 23/10/2011 21:12, Ulf Zibis wrote:
>> Shouldn't you better name it in capital letters? :
>>     static final AcceptAllFilter INSTANCE = new AcceptAllFilter();
>> -Ulf
> Thanks Ulf, we sort this out once we finalize the changes after Mike re-runs his tests.
> -Alan

More information about the nio-dev mailing list