8196956: (ch) More channels cleanup

Alan Bateman Alan.Bateman at oracle.com
Wed Feb 7 18:09:17 UTC 2018

On 07/02/2018 18:03, Roger Riggs wrote:
> Hi Alan,
> AbstractSelectableChannel.java: 78:  Keeping the boolean consistent 
> with the methods
> will make the code a bit easier to maintain.
It is inverted to avoid the volatile write at initialization time. It 
makes configureBlocking a bit harder to read but I think we can live 
with that.


More information about the nio-dev mailing list