API REVIEW: WebView.scale property (for JavaFX 3.0 now)
Peter.Zhelezniakov at oracle.com
Mon Jul 23 02:21:08 PDT 2012
On 07/20/12 20:14, Leonid Popov wrote:
> It sounds reasonable, assuming that scaleX/scaleY have slightly
> different semantics (they apply to the whole view, including scrollbars,
> while the proposed property should affect WebView contents only). Any
> other opinions on scale vs. zoom?
I named it scaleProperty for consistency as we already had
fontScaleProperty. OTOH I agree 'zoom' may sound more familiar and
intuitive than 'scale'. I don't have strong preference now.
Should we name it just zoomProperty, or maybe zoomFactorProperty? Native
speakers please advise!
More information about the openjfx-dev