[API Review]: Node validation
John C. Turnbull
ozemale at ozemail.com.au
Mon Jul 8 04:58:57 PDT 2013
Yes, I think "validate" is a very poor name choice as there are many
connotations of that word.
It would be better to use a more specific name even if it means using more
than one word.
From: openjfx-dev-bounces at openjdk.java.net
[mailto:openjfx-dev-bounces at openjdk.java.net] On Behalf Of Pavel Safrata
Sent: Monday, 8 July 2013 21:21
To: openjfx-dev at openjdk.java.net
Subject: Re: [API Review]: Node validation
one more discussion topic: perhaps the "validate" name is too general?
Maybe we can come up with more descriptive name? There are all kinds of
nodes and sometimes this name can be misleading (not ringing the layout bell
at all). For example TextField.validate() may look like validating the
input. Also I wouldn't be surprised if users run into problems with custom
nodes having their "validate" methods for different purposes.
On 3.7.2013 14:33, Martin Sladecek wrote:
> JIRA: https://javafx-jira.kenai.com/browse/RT-31133
> I propose a single method "public final void validate()" to be added
> to Node class. The validate method would ensure that the metrics
> (layout bounds) of the Node are valid with regards to the current
> scenegraph (CSS & layout).
> Together with this change, Parent.layout() will be deprecated.
> In my current implementation, validate() method works only if the Node
> is in a Scene. To make it work without a Scene, we'd need to do do
> some small adjustments to CSS (doesn't work with getScene() == null).
> But I'm not sure if such feature would be useful.
More information about the openjfx-dev