JavaFX fails to build with multiple different issues

Ty Young youngty1997 at
Mon Dec 3 23:56:39 UTC 2018

So here is an odd one: JavaFX is now longer building on Arch Linux even 
on a previous source directory that did compile just fine. I'm guessing 
that something was updated and isn't compatible with JavaFX's build 
scripts but I'm not entirely sure what exactly it is.

(Note: just to make sure the files didn't magically become corrupt or 
something I redownloaded from the Github mirror. Same issue.)

First error is this:

118: The variable [files] is declared final but is reassigned
. At [118:21]  @ line 118, column 21.
                        files += file;

which is easy enough to fix by simply removing final from line 105. Even 
though this was clearly an issue(why use final on local variables? I've 
never understood why people do it...), I'm not entirely sure why it's 
throwing an error now. Is it because Groovy is a scripting language and 
the build scripts never used to follow that logic path?

Next issue is this:

 > Could not get unknown property 'moduleEmptyPublicationJarLinux' for 
task set of type org.gradle.api.internal.tasks.DefaultTaskContainer

which I'm not sure on how to resolve. Thinking that it may be related to 
my custom built JDK I tried swapping it out for an older one that I know 
worked before and yet it fails all the same.

More information about the openjfx-dev mailing list