RFR: 8253356: JavaFX Terminology Refresh [v2]
arapte at openjdk.java.net
Wed Dec 16 13:38:59 UTC 2020
On Wed, 16 Dec 2020 13:20:23 GMT, Kevin Rushforth <kcr at openjdk.org> wrote:
>> Replace archaic/non-inclusive words in JavaFX with more neutral terms. See [JDK-8253315](https://bugs.openjdk.java.net/browse/JDK-8253315) for background information.
>> The following changes are made:
>> 1. Rename whitelist/blacklist to allowlist/rejectlist
>> 2. Rename `MasterTimer` to `PrimaryTimer` in animation and toolkit implementation
>> 3. Rename local variable master in a couple places
>> 4. Remove master from comments in a few other places
>> This PR doesn't remove uses of the word master where there is no connotation of slavery.
>> Note that it is out of scope of this PR to address similar issues in 3rd-party code, such as WebKit or GStreamer. We will pick up any relevant changes after they are available in the upstream sources.
> Kevin Rushforth has updated the pull request incrementally with one additional commit since the last revision:
> Respond to feedback: change masterWindow to mainWindow in iOS files
Looks good to me.
Marked as reviewed by arapte (Reviewer).
More information about the openjfx-dev