VectorAPI Variable Shift intrinsics
shravya.rukmannagari at intel.com
Fri Apr 20 19:05:31 UTC 2018
I changed the name from meta to op_arity. Please find the modified patch below.
From: Paul Sandoz [mailto:paul.sandoz at oracle.com]
Sent: Thursday, April 19, 2018 5:33 PM
To: Rukmannagari, Shravya <shravya.rukmannagari at intel.com>
Cc: panama-dev at openjdk.java.net
Subject: Re: VectorAPI Variable Shift intrinsics
It looks good, but i find the parameter meta a little too opaque, perhaps “arity" or “op_arity" would be a better name? where a 0 value means don’t care or undefined?
> On Apr 19, 2018, at 3:57 PM, Rukmannagari, Shravya <shravya.rukmannagari at intel.com> wrote:
> Hi All,
> I would like to contribute a patch adding vector intrinsics support for Vector API variable shift functions for int and long data types.
> Could you please review the patch here: http://cr.openjdk.java.net/~srukmannagar/VectorAPI_shiftVar/webrev/
More information about the panama-dev