[foreign] Running tests on Windows

Jorn Vernee jbvernee at xs4all.nl
Wed Sep 19 17:50:15 UTC 2018

Henry Jen schreef op 2018-09-19 19:11:
> On Sep 19, 2018, at 9:07 AM, Jorn Vernee <jbvernee at xs4all.nl> wrote:
>> Henry Jen schreef op 2018-09-19 17:23:
>>> On Sep 19, 2018, at 5:00 AM, Jorn Vernee <jbvernee at xs4all.nl> wrote:
>>>> And then of course one of the biggest things is getting jextract to 
>>>> build and run. Currently the build system is not picking up 
>>>> libclang. When explicitly specifying it with 
>>>> --with-libclang='/cygdrive/j/LLVM' I still get the "Cannot locate 
>>>> libclang!" warning. I wanted to ask what value and files it's 
>>>> actually looking for? (I've also tried some of the additional flags 
>>>> from makeautoconf/lib-clang.m4, but to no avail).
>>> —with-libclang should point to a directory has include/clang-c and
>>> lib/libclang.dll. If include and lib are not under the same 
>>> directory,
>>> you can use —with-libclang-include and —with-libclang-lib instead.
>> I have tried all of these flags together:
>> --with-libclang=/cygdrive/j/LLVM 
>> --with-libclang-include=/cygdrive/j/LLVM/include 
>> --with-libclang-include-aux=/cygdrive/j/LLVM/lib 
>> --with-libclang-lib=/cygdrive/j/LLVM/bin
> Try remove —with-libclang and use the rest three. Explicit setting
> —with-libclang cause the other options to be ignored.

Still the same problem I'm afraid.

It's probably kind of hard to debug this remotely, so for now I'll focus 
on getting the other tests to work, and come back to this later.


More information about the panama-dev mailing list