[foreign] Running tests on Windows

Maurizio Cimadamore maurizio.cimadamore at oracle.com
Wed Sep 19 20:05:31 UTC 2018

First off - thanks for doing this; it's immensely appreciated.

as for this:

JtregNativeJdk.gmk:96: warning: ignoring old recipe for target 

I'm getting similar warnings too, but for Hello.so. I think that's how 
supposed to work but then again I'm not a build guru and I haven't 
digged too deep (yet) to figure out what's causing that. But I get that 
too, so I think we can ignore that for the time being.

I agree that we should focus on Win x64.

About the 'cannot locate clang' that's the first hurdle that we should 
be able to solve. First question: what's in your /cygdrive/j/LLVM 
folder? Is that a straight download of the LLVM binaries?


On 19/09/18 18:50, Jorn Vernee wrote:
> Henry Jen schreef op 2018-09-19 19:11:
>> On Sep 19, 2018, at 9:07 AM, Jorn Vernee <jbvernee at xs4all.nl> wrote:
>>> Henry Jen schreef op 2018-09-19 17:23:
>>>> On Sep 19, 2018, at 5:00 AM, Jorn Vernee <jbvernee at xs4all.nl> wrote:
>>>>> And then of course one of the biggest things is getting jextract 
>>>>> to build and run. Currently the build system is not picking up 
>>>>> libclang. When explicitly specifying it with 
>>>>> --with-libclang='/cygdrive/j/LLVM' I still get the "Cannot locate 
>>>>> libclang!" warning. I wanted to ask what value and files it's 
>>>>> actually looking for? (I've also tried some of the additional 
>>>>> flags from makeautoconf/lib-clang.m4, but to no avail).
>>>> —with-libclang should point to a directory has include/clang-c and
>>>> lib/libclang.dll. If include and lib are not under the same directory,
>>>> you can use —with-libclang-include and —with-libclang-lib instead.
>>> I have tried all of these flags together:
>>> --with-libclang=/cygdrive/j/LLVM 
>>> --with-libclang-include=/cygdrive/j/LLVM/include 
>>> --with-libclang-include-aux=/cygdrive/j/LLVM/lib 
>>> --with-libclang-lib=/cygdrive/j/LLVM/bin
>> Try remove —with-libclang and use the rest three. Explicit setting
>> —with-libclang cause the other options to be ignored.
> Still the same problem I'm afraid.
> It's probably kind of hard to debug this remotely, so for now I'll 
> focus on getting the other tests to work, and come back to this later.
> Thanks,
> Jorn

More information about the panama-dev mailing list