[security-dev 01451]: Another code reviewer? (Re: Code review request (was Re: [Fwd: Re: [Fwd: Seeking JDK/Kerberos assistance]]))
Max (Weijun) Wang
Weijun.Wang at Sun.COM
Tue Dec 8 19:54:44 PST 2009
1. Add synchronized modifier to all methods
I need another code reviewer, want to backport it to 6u20.
The bug is at --
The description of the fix is at --
On Dec 9, 2009, at 8:59 AM, Valerie Peng wrote:
> Hi, Max,
> Ok, it sounds like there isn't an easy way to centralize the KDC
> accessibility policy, timeout, and the number of retries. Let's just
> leave it as is then.
> Your changes generally looks fine and here are my only comments:
> 1. PreferredKDCList.bads is of type HashSet whose access needs to be
> explicitly synchronized?
> 2. Some nitpicking on naming, it seems somewhat confusing to name
> the class "PreferredKDCList" when it includes all kdcs for that
> specific realm. Maybe something like "KdcAvailability",
> "KdcAccessibility", or "KdcByAvailability", etc. Same goes for the
> local variable "goodkdcs" in its list(String) method which actually
> contains all kdcs for the specific realm in the end.
> On 11/22/09 22:10, Max (Weijun) Wang wrote:
More information about the security-dev