7092897: sun.security.util.Cache should be generified
xuelei.fan at oracle.com
Mon Oct 17 20:07:25 PDT 2011
I only have a few very minor suggestions.
-> 264 this.queue = soft ? new ReferenceQueue<V>() : null;
I would like to remove the generic "V" in the right side of the assignment:
264 this.queue = soft ? new ReferenceQueue<>() : null;
-> 255 private final ReferenceQueue<V> queue;
>From my first look at the update, I think the real generic type should
be "CacheEntry<K,V>", instead of "V". However, because SoftCacheEntry
class need to extend SoftReference<V>, we have to use a dummy type "V"
here. I was wondering we may want to add a line or two comments here.
Otherwise, looks fine to me.
On 10/18/2011 2:51 AM, Sean Mullan wrote:
> Hi Xuelei,
> Would you be able to review this fix?
More information about the security-dev