RFR: 8165996:PKCS11 using NSS throws an error regarding secmod.db when NSS uses sqlite

Seán Coffey sean.coffey at oracle.com
Wed Mar 14 14:48:07 UTC 2018


Looking to backport this fix to jdk8u-dev.  Contributed to JDK Project 
by Martin Balao.

https://bugs.openjdk.java.net/browse/JDK-8165996
webrev : http://cr.openjdk.java.net/~coffeys/webrev.8165996.8u/webrev/

The test/jdk/sun/security/pkcs11/PKCS11Test.java edits didn't seem 
applicable to jdk8u.

Also, I edited sun/security/pkcs11/Secmod/TestNssDbSqlite.java to 
exclude test where NSS Provider
didn't register. (line 66). In particular, I saw this while running 
32bit JDK tests on 64 bit Linux.

-- 
Regards,
Sean.



More information about the security-dev mailing list