See you at JVMLS

timo.kinnunen at timo.kinnunen at
Sun Aug 9 01:30:20 UTC 2015


Inspired by these words, I tried it out for myself and ... it didn’t work. Specifically, and in the order of appearance, this didn’t work:

1. I didn’t find a link to instructions to try it out in my emails within the last 30 days. Eventually I picked a link in random to some change set in the Valhalla repository. There I navigated to its root and saw a change to README-builds.html 5 weeks ago. I took that as my intended destination. Action for improvement: it would be helpful to include a short reminder for where to go to get started when asking people try something out. Even if that’s been mentioned previously a little bit a repetition doesn’t cost anything.
2. The installation information for Cygwin is somewhat inaccurate as written. Specifically:
a. gawk.exe from Cygwin category Utils, contained in package awk: there is no package by that name, but the package gawk exists in category Base and is included by default. Action for improvement: this requirement seems to be outdated and should be removed.
b. file.exe from category Utils, contained in package file: package file can’t be found in the indicated category, but the package is found in category Base and is included by default. Action for improvement: this requirement seems to be outdated and should be removed.
3. The website for Mercurial cautions about the version of hg included in Cygwin without going into specifics. It is unclear from the README whether the build has been tested to work using the standalone Mercurial, the one in Cygwin or both. I took this to mean either one would be OK and picked hg from Cygwin. Action for improvement: mentioning both versions and anything special that should be considered when making the decision would let people make better decisions for their circumstances.
4. The website for Visual Studio doesn’t mention any Express edition. There is a Visual Studio 2015 Community edition, which is free and is intended for research, teaching, open-source and non-enterprise use. This appears to be the intended replacement for the 2013 Express edition, so I went with that. Action for improvement: the build should continue replacing old legacy components with their more modern counterparts.
5. Running bash ./configure results in configure: error: Could not find required tool for CMP error. Action for improvement: The package diffutils found in category Utils contains cmp.exe, which seems to be required by the build. This requirement should be listed in the table with the other requirements for Cygwin.

With the previous done and the variable VS120COMNTOOLS set to point to where VS140COMNTOOLS points, running bash ./configure now results in:

configure: Found Visual Studio installation at /cygdrive/d/build/Microsoft Visual Studio 14.0/ using VS120COMNTOOLS variable
configure: Found Microsoft Visual Studio 2013
configure: Rewriting VS_ENV_CMD to "/cygdrive/d/build/Microsoft Visual Studio 14.0/vc/bin/amd64/vcvars64.bat"
configure: Trying to extract Visual Studio environment variables
'D:/build/Microsoft' is not recognized as an internal or external command,
operable program or batch file.

As predicted by the README-builds.html, the configure script is handling the path "D:/build/Microsoft Visual Studio 14.0/vc/bin/amd64/vcvars64.bat" improperly, resulting in it getting cut off at the first space character. As could be guessed, the script doesn’t do very well after that.

And that’s why it didn’t work.

Sent from Mail for Windows 10

From: Brian Goetz
Sent: Saturday, August 8, 2015 18:06
To: valhalla-dev at
Subject: See you at JVMLS

I'll be doing a talk on the path from Model 1 to Model 2 (and a glimpse 
of Model 3) at JVMLS next week.  Hope to see some of you there.  Videos 
should go up on the Java YouTube channel fairly quickly after the 

In the meantime ... I'll just note that we've had 50+ messages on the 
various "Model 2" threads and none of them started with "I tried it out 

So a reminder ... the most valuable input the community can give in this 
process is to provide *actual experience reports*.  That's the main 
reason we make the significant investment in making the code and design 
sketches available early -- so that people can actually try it out, and 
help us see the holes that we might have missed.

More information about the valhalla-dev mailing list