> A small comment on the naming. I'm wondering why the name VarHandle? > It feels like FieldHandle would be a better name. VarHandle suggests > that it would be able to apply it to stack variable, parameters etc? VarHandle supports access to array elements and off-heap variables as well. Fields are too specific.