RFR: [MVT] Rename DeriveValueType annotation

Maurizio Cimadamore maurizio.cimadamore at oracle.com
Mon Jul 24 16:00:30 UTC 2017


Hi,
the special annotation that triggers generation of a derived value 
should be renamed from @DeriveValueType to @ValueCapableClass (which is 
also a term used in the spec draft).

After some internal discussion we agreed that adding flags, or 
deprecating old annotation was not worth the extra interim complexity, 
so we're aiming for a straight rename.

As this touches a lot of stuff, please double check :-)

Webrevs:

http://cr.openjdk.java.net/~mcimadamore/8185143-hotspot/

http://cr.openjdk.java.net/~mcimadamore/8185143-jdk/

http://cr.openjdk.java.net/~mcimadamore/8185143-langtools/

Maurizio



More information about the valhalla-dev mailing list