RFR: [MVT] Rename DeriveValueType annotation
paul.sandoz at oracle.com
Thu Jul 27 22:57:44 UTC 2017
Should the annotation be moved to a non-internal package?
> On 24 Jul 2017, at 09:00, Maurizio Cimadamore <maurizio.cimadamore at oracle.com> wrote:
> the special annotation that triggers generation of a derived value should be renamed from @DeriveValueType to @ValueCapableClass (which is also a term used in the spec draft).
> After some internal discussion we agreed that adding flags, or deprecating old annotation was not worth the extra interim complexity, so we're aiming for a straight rename.
> As this touches a lot of stuff, please double check :-)
More information about the valhalla-dev