RFR: [MVT] Rename DeriveValueType annotation

Maurizio Cimadamore maurizio.cimadamore at oracle.com
Thu Jul 27 23:01:52 UTC 2017



On 27/07/17 23:57, Paul Sandoz wrote:
> Looks ok.
>
> Should the annotation be moved to a non-internal package?
Sorry for the confusion, this was already pushed earlier today (in an 
attempt to push for spec parity).

Regarding packages and names, I think an overhaul is needed. I'd like to 
rename ValueType to something like ValueHandles. Then, have a Lookup in 
there which can be constructed by passing the VCC:

ValueHandles.Lookup(Point.class).findGetter(...)

and the likes. I think that would make the transition towards real JDK 
easier in the long run.

As for packages, I think it's also time we start to figure out how to do 
the 'incubator' bits - e.g. John's document speaks about value-capable 
modules, so we should probably start creating a new module and put all 
the values stuff in there maybe?

Maurizio
>
> Paul.
>
>> On 24 Jul 2017, at 09:00, Maurizio Cimadamore <maurizio.cimadamore at oracle.com> wrote:
>>
>> Hi,
>> the special annotation that triggers generation of a derived value should be renamed from @DeriveValueType to @ValueCapableClass (which is also a term used in the spec draft).
>>
>> After some internal discussion we agreed that adding flags, or deprecating old annotation was not worth the extra interim complexity, so we're aiming for a straight rename.
>>
>> As this touches a lot of stuff, please double check :-)
>>
>> Webrevs:
>>
>> http://cr.openjdk.java.net/~mcimadamore/8185143-hotspot/
>>
>> http://cr.openjdk.java.net/~mcimadamore/8185143-jdk/
>>
>> http://cr.openjdk.java.net/~mcimadamore/8185143-langtools/
>>
>> Maurizio
>>



More information about the valhalla-dev mailing list