Return value type fields in registers
rwestrel at redhat.com
Wed May 3 08:42:05 UTC 2017
Thanks for looking at this.
> - What is 'skip' used for?
It's useless indeed.
> - you can merge the check in line 232 with the check in line 252
It's not that simple: line 245 changes the save_oop_result value so the
flag has to be retested.
> - 'return_values' is a bit misleading because it contains Handles for
> oop fields or the oop return and not all returned values. Maybe rename
> to 'return_oops' or 'return_handles'.
> - line 3176, missing whitespace
I have a revised change coming that will take care of your comments.
More information about the valhalla-dev