Review Request: 8238358: Implementation of JEP 371: Hidden Classes
Alan.Bateman at oracle.com
Wed Apr 1 14:26:08 UTC 2020
On 31/03/2020 20:25, Mandy Chung wrote:
> Alex's feedback: rename isHiddenClass to isHidden as it can be a
> hidden class or interface.
> `isLocalClass` and `sAnonymousClass` are correct because the Java
> language only has local classes and anon classes, not local interfaces
> or anon. interfaces. `isHidden` is like `isSynthetic`, it could be a
> class or interface.
> Although isHiddenClass seems clearer, I'm okay to rename it to
I went through the java.base changes in webrev.03-delta. The rename to
isHidden and the updated javadoc looks good. There are a few additional
drive-by updates to the javadoc, including isSynthetic, they all look
Maybe I missed it going by, but why is the isHidden check in the field
offset methods on sun.misc.Unsafe rather than the internal Unsafe?
More information about the valhalla-dev