RFR [lworld] 8239929: Object.newIdentity() replacement for new Object()

John Rose john.r.rose at oracle.com
Fri Feb 28 03:40:12 UTC 2020


On Feb 25, 2020, at 11:20 AM, Roger Riggs <Roger.Riggs at oracle.com> wrote:
> 
> IdentityInstance

Does anyone else find this name to verbose?

Folks will see Object$IdentityInstance, like they see AbstractList$SubList.

I suggest s/IdentityInstance/Identity/, so Object$Identity is the class.



More information about the valhalla-dev mailing list