[lworld] RFR: 8249886: Rename -XX: InlineArrayElemMaxFlat* options

Frederic Parain fparain at openjdk.java.net
Thu Jul 23 18:18:39 UTC 2020

On Thu, 23 Jul 2020 17:06:10 GMT, Harold Seigel <hseigel at openjdk.org> wrote:

> Hi
> Please review this change to rename InlineArrayElemMaxFlatSize to FlatArrayElemMaxFlatSize and rename
> InlineArrayElemMaxFlatOops to FlatArrayElemMaxFlatOops.
> The change was tested with tiers 1-2 on Windows, MacOSX, and Linux x64.
> Thanks, Harold


Thank you for continuing the renaming effort.
However, the new names of the VM options sound weird.
Instead of InlineArrayElemMaxFlatSize, could you use FlatArrayElementMaxSize (no need to repeat Flat).
And FlatArrayElemMaxFlatOops seems confusing with the term FlatOops. Could you replace it with FlatArrayElementMaxOops?

Thank you,



PR: https://git.openjdk.java.net/valhalla/pull/119

More information about the valhalla-dev mailing list