RFR: [nestmates] rename Class::isHiddenClass to Class::isHidden
mandy.chung at oracle.com
Tue Mar 31 23:52:48 UTC 2020
On 3/31/20 4:45 PM, David Holmes wrote:
> Hi Mandy,
> The rename looks good. The misc import cleanups are also good. :)
> On 1/04/2020 9:09 am, Mandy Chung wrote:
>> Alex observes that a class or interface can be hidden and so he
>> suggest to rename `isHiddenClass` to `isHidden` as it's not limited
>> to class only.
>> `isHidden` is like `isSynthetic`, it could be a class or interface.
>> `isLocalClass` and `sAnonymousClass` are specific for class only
>> because the Java language only has local classes and anon classes,
>> not local interfaces or anon. interfaces. `isMemberClass` isn't
>> correct since it can be a class or interface.
More information about the valhalla-dev