<div dir="ltr">This problem came back today.  The same rsync command to <a href="http://cr.openjdk.java.net">cr.openjdk.java.net</a> that succeeded last week is failing this week.<div>Its IP address has changed, so I'm guessing y'all updated it.</div>
<div>I've tried with or without --protocol=29.</div><div><br></div><div>Can other people successfully rsync?</div><div>sftp is still working fine.</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, May 30, 2012 at 6:21 PM, David Holmes <span dir="ltr"><<a href="mailto:david.holmes@oracle.com" target="_blank">david.holmes@oracle.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Tim,<div class=""><br>
<br>
On 31/05/2012 3:19 AM, Tim Bell wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi David:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
It's possible my local rsync version has changed but does anyone know<br>
why I would get this error?<br>
</blockquote>
<br>
cr.ojn is still running an old version of rsync:<br>
<br>
% /usr/bin/rsync --version<br>
rsync version 2.6.9 protocol version 29<br>
<br>
If your rsync is using a protocol version newer than 29, you need to add<br>
"--protocol=29" to your command line. Give this a try and let me know if<br>
it does not work for you.<br>
</blockquote>
<br></div>
I'm using that already I'm afraid. I ran into the protocol issue some take back.<br>
<br>
But you gave me the clue I needed :) Turns out rsync is using the local path to the rsync binary as the remote path for the rsync binary. In my case the local path is now  /pkg/local/bin/rsync but I need /usr/bin/rsync remotely. Setting the --rsync-path option fixed it.<br>

<br>
Thanks,<br>
David<div class="HOEnZb"><div class="h5"><br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
I'll investigate updating the rsync used on the CR server, as Mark<br>
suggested long ago.<br>
<br>
Tim<br>
<br>
<br>
</blockquote>
</div></div></blockquote></div><br></div>