[OpenJDK 2D-Dev] Black screen on Raspberry Pi / Manjaro

Kustaa Nyholm kustaa.nyholm at sparetimelabs.com
Wed Jul 28 19:11:36 UTC 2021


I'm afraid this is the wrong mailing list or venue but have to start from somewhere.

I just tested my Swing app using OpenJDK 11.0.1 on Raspberry Pi 4 / Manjaro and it worked great.

I then enabled the OpenGL pipeline with


and console confirmed that the pipeline was enabled.

The rending now  fails as follows:

During the initial rendering of Swing components (it is a bit slow so I can see what happens)
a lot of extra black follows or preceeds rendering  of every Swing component. When the
rendering is complete the whole window goes black except a white border around an
OpenGL canvas component. 

As I move the cursor around the component under the cursor flashes correctly rendered but
remains black.

If I resize the window, the whole window flashes briefly (much much faster that what
normal rendering takes place) with the correct rendering but then goes black again.

I tried this with X11 and Wayland enabled KDE (if it makes a difference, perhaps Java2D
rendring is not affected by the Desktop rendering....

Is this a driver issue?

If so where should I turn next to ask questions like what driver I'm using and whom 
to report the problem?

I'm rather new to Linux / Raspberry so the driver / open source bug reporting
is kind of unclear to me...

wbr Kusti

More information about the 2d-dev mailing list