Feedback from Hacking Java 9 at the Chicago Java Users Group

Freddy Guime freddy.guime at
Mon Jun 27 13:31:29 UTC 2016

Hello everyone! We had a Hacking JDK 9 session a little while ago, but finally collected and put all the comments from our members on feedback. It was great having Heather and Charlie move things along and work with the Chicago Java Community to try and play with JDK9.

Let me know if you want me to go back and get more details on any of these. 



Jan Fetyko:
Trying out jdk9 build 9-ea+112: I can compile and run. But jvisualvm crashes with exception : Exception in thread "main" java.lang.SecurityException: setContextClassLoader at jdk.internal.misc.InnocuousThread.setContextClassLoader(java.base at 9-ea/

Charlie and Heather both did a fantastic presentation followed by a hands on session with Java 9 and the people there. We had some issues with having the Spring IDE recognizing the JDK. It is built on an eclipse platform but for some odd reason it would not recognize the JDK 9 software. We spoke with Charlie about it and he had a few ideas and suggestions on how to fix this issue.

We tried setting up JDK 9 on Netbeans. It would see the JDK 9 but when it came to switching it from Java 1.8 it locked up the app and it req. the task manager to kill the app. The good thing was Heather was able to help us with this issue and show that there was another download that we should use when hooking it up to Netbeans. We did get the JDK running in a command line to compile some code we wrote up and run it

Thank you to Heather, Charlie & everyone at the CJUG and IMC Financial Markets

Jonathan Ross:
Ran into a couple of issues with playing with Java 9 on one of my projects today:
* A regression in type inference (easily fixed by simplifying the expressions/spelling out the type parameters)
* A peculiar change involving @Nullable @Assisted injects in guava (fixed by using Optional<...> instead)
* Using IntelliJ 2016.1, I could compile and run everything (to 1.8 target) fine using the 111 build, but when I switched to 112 things broke: 
Error:IntelliLang Pattern Validator: sun/misc/Resource
* When playing with jshell, I found that java.util.ServiceLoader was not working as expected.

Mary G:
Question about the Build 112 for MacOS/X, there's no zip or tar.gz distribution, and as a result, when i install the dmg, the java9-ea version has overwritten my previous java8 installation. Would it be possible to have the zip'ped distribution for Mac? Thanks!

John Krupka:
Tried to start groovyConsole and it crashed. We also tried installing Leiningen for Clojure and that also exploded with missing sun.misc.Launcher.

Matt Sicker:
Got a weird issue with locales
assertEquals("12,00 €", new MessageFormat("{0,number,currency}", Locale.FRANCE).format(new Object[] {12}));
Same problem with Locale.GERMANY, Locale.ITALY, etc.


Freddy Guime
Community Leader
Chicago Java Users Group
freddy.guime at

More information about the adoption-discuss mailing list