Feedback from Hacking Java 9 at the Chicago Java Users Group

dalibor topic dalibor.topic at
Wed Jun 29 13:02:57 UTC 2016

On 27.06.2016 15:31, Freddy Guime wrote:
> Jan Fetyko:
> Trying out jdk9 build 9-ea+112: I can compile and run. But jvisualvm crashes with exception : Exception in thread "main" java.lang.SecurityException: setContextClassLoader at jdk.internal.misc.InnocuousThread.setContextClassLoader(java.base at 9-ea/

Please try again with the latest Early Access build, currently that's 
build 124. If the issue persists, please contact its developers, as 
Martijn indicated.

> Mirko:
>It is built on an eclipse platform but for some odd reason it would not recognize the JDK 9 software.

Please see

> Jonathan Ross:
> Ran into a couple of issues with playing with Java 9 on one of my projects today:
> * A regression in type inference (easily fixed by simplifying the expressions/spelling out the type parameters)

Did you run into ? If 
not, please try again with the latest early access build, and file an 
issue at if the problem persists with a reproducer.

> * Using IntelliJ 2016.1, I could compile and run everything (to 1.8 target) fine using the 111 build, but when I switched to 112 things broke:
> Error:IntelliLang Pattern Validator: sun/misc/Resource

Does the problem still occur with the latest early access build?

> * When playing with jshell, I found that java.util.ServiceLoader was not working as expected.

Does the problem still occur with the latest early access build?

> Mary G:
> Would it be possible to have the zip'ped distribution for Mac? Thanks!

Please file an issue on There was a similar issue for 
Windows at - I don't 
think there was one filed for OS X.

Meanwhile, if you'd like to create your own build, please see 

> John Krupka:
> Tried to start groovyConsole and it crashed.

Does the problem still occur with the latest early access build?

> We also tried installing Leiningen for Clojure and that also exploded with missing sun.misc.Launcher.

Please see

> Matt Sicker:
> Got a weird issue with locales
> assertEquals("12,00 €", new MessageFormat("{0,number,currency}", Locale.FRANCE).format(new Object[] {12}));
> Same problem with Locale.GERMANY, Locale.ITALY, etc.

Does the problem still occur with the latest early access build?

Please see 

dalibor topic

<> Dalibor Topic | Principal Product Manager
Phone: +494089091214 <tel:+494089091214> | Mobile: +491737185961

ORACLE Deutschland B.V. & Co. KG | Kühnehöfe 5 | 22761 Hamburg

ORACLE Deutschland B.V. & Co. KG
Hauptverwaltung: Riesstr. 25, D-80992 München
Registergericht: Amtsgericht München, HRA 95603

Komplementärin: ORACLE Deutschland Verwaltung B.V.
Hertogswetering 163/167, 3543 AS Utrecht, Niederlande
Handelsregister der Handelskammer Midden-Niederlande, Nr. 30143697
Geschäftsführer: Alexander van der Ven, Jan Schultheiss, Val Maher

<> Oracle is committed to developing
practices and products that help protect the environment

More information about the adoption-discuss mailing list