Raw String Literals indentation management
brian.goetz at oracle.com
Thu Jun 7 17:48:05 UTC 2018
> Part of the goal was to shorten the name to reduce the annoyance quotient. “reindent” speaks to me more than “leftMargin” (starts searching thesaurus.) The combo makes sense too. Then you start thinking in terms of indent is just reindent without the magic.
reindent() is OK by me; its a little longer but it says what it means, and still less fussy than trimMargin() or autoMagicReindent().
undent() is shorter, but sounds more like what happens at an auto-body repair shop :)
More information about the amber-spec-observers