Raw String Literals indentation management
guy.steele at oracle.com
Thu Jun 7 17:49:49 UTC 2018
> On Jun 7, 2018, at 1:48 PM, Brian Goetz <brian.goetz at oracle.com> wrote:
>> Part of the goal was to shorten the name to reduce the annoyance quotient. “reindent” speaks to me more than “leftMargin” (starts searching thesaurus.) The combo makes sense too. Then you start thinking in terms of indent is just reindent without the magic.
> reindent() is OK by me; its a little longer but it says what it means, and still less fussy than trimMargin() or autoMagicReindent().
> undent() is shorter, but sounds more like what happens at an auto-body repair shop :)
Or redent(), which happens a week later. :-)
More information about the amber-spec-observers