kevinb at google.com
Fri Feb 1 19:25:27 UTC 2019
I like `break-with value();` much better than `break value();` - and would
also agree that that change alone shouldn't require re-previewing the
On Thu, Jan 17, 2019 at 11:28 AM Brian Goetz <brian.goetz at oracle.com> wrote:
> > Being able to call this something like `break-with v` (or some other
> derived keyword) would have made this all a lot simpler. (BTW, we can still
> do this, since expression-switch is still in preview.)
> It seems we’re all in favor of break-with over unadorned “break”?
> Which feeds into the bigger question about promoting expression switch to
> final in 13. I don’t think this syntactic change on its own merits
> re-previewing the feature; this is exactly the sort of “feature is
> finished, but we might change the paint color based on feedback” kind of
> thing that the preview mechanism was intended for.
> We don’t have to make this decision quite yet, but sometime between now
> and feature-freeze for 13 (June) we have to take one of the following
> - File a JEP to make it a permanent feature, possibly with changes
> - File a JEP to re-preview it, possibly with changes
> - Withdraw the feature
> We can continue to gather feedback on the feature and revisit later.
Kevin Bourrillion | Java Librarian | Google, Inc. | kevinb at google.com
More information about the amber-spec-observers