<AWT Dev> Bug 6913179, FileDialog uses native GTK under Linux: first patch

Peter Zhelezniakov Peter.Zhelezniakov at Sun.COM
Thu Feb 11 02:26:08 PST 2010

Hi Costantino,

Costantino Cerbo wrote:
 > It works correctly, but only if we don't use the GTK L&F.
 > I didn't realise it and this is a very useful clue: it means that we
 > do something wrong with the initialization of GTK.
 > With the GTK L&F, I get these errors:
 >   Xlib: sequence lost (0x11fae > 0x2233) in reply type 0x1c!
 >   *** glibc detected ***
 > /home/c.cerbo/openjdk-awt/jdk/build/linux-i586/bin/java: double free
 > or corruption (fasttop): 0x912db9d0 ***
 >   *** glibc detected ***
 > /home/c.cerbo/openjdk-awt/jdk/build/linux-i586/bin/java: double free
 > or corruption (out): 0x912d2d10 ***

I tried again, this time with your newest patch

My only change was to start a new thread in GtkFileDialogPeer (see 
gtkfd2.patch, attached). It worked with GTK LAF for me, and i wasn't 
getting any messages. I was running attached GtkFD.java on a Gentoo box 
with gtk+-2.16.6, and was using latest jdk7 sources.

Could you try my patch and test on your machine?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: GtkFD.java
Type: text/x-java
Size: 1228 bytes
Desc: not available
Url : http://mail.openjdk.java.net/pipermail/awt-dev/attachments/20100211/c45ef0c3/GtkFD.java 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: gtkfd2.patch
Url: http://mail.openjdk.java.net/pipermail/awt-dev/attachments/20100211/c45ef0c3/gtkfd2.patch 

More information about the awt-dev mailing list