<AWT Dev>  Review request: new macro for conversion to jboolean
Sergey.Bylokhov at oracle.com
Wed Mar 19 18:36:39 UTC 2014
Can somebody from the core-libs team take a look?
On 3/17/14 10:31 PM, Anthony Petrov wrote:
> Personally, I'd call it to_jboolean(obj), but IS_TRUE(obj) sounds good
> to me too. Either way, I'm fine with the fix.
> best regards,
> On 3/17/2014 7:01 PM, Sergey Bylokhov wrote:
>> This review request is for the new macro, which simplify conversion to
>> jboolean. It will be useful for fixing parfait warnings.
>> We have a lot of places, where we cast some type to jboolean:
>> BOOL = retVal;
>> return (jboolean) retVal;
>> WARNING: Expecting value of JNI primitive type jboolean: mismatched
>> value retVal with size 32 bits, retVal used for conversion to int8 in
>> +++ b/src/share/native/common/jni_util.h Mon Mar 17 18:28:48 2014
>> @@ -277,6 +277,7 @@
>> #define IS_NULL(obj) ((obj) == NULL)
>> #define JNU_IsNull(env,obj) ((obj) == NULL)
>> +#define IS_TRUE(obj) ((obj) ? JNI_TRUE : JNI_FALSE)
>> I am not sure about the name, probably someone have a better suggestion?
>> The fix is for jdk9/dev.
>> Best regards, Sergey.
Best regards, Sergey.
More information about the awt-dev