<AWT Dev> [12] Review Request: 8211833 Javadoc cleanup of java.applet package

Sergey Bylokhov Sergey.Bylokhov at oracle.com
Thu Nov 1 20:51:03 UTC 2018

For the record, the last version:

On 31/10/2018 00:05, Philip Race wrote:
> Changing it to "strings" sounds fine.
> Pre-approved.
> -phil.
> On 10/30/18, 6:41 PM, Sergey Bylokhov wrote:
>>> This one looks odd :
>>> + * Each element of the array should be a set of three {@code Strings}
>>> Since there is no class called "Strings".
>>> Is that how plurals are handled in other parts of the javadoc ?
>>> I thought I might have used {@code String}s instead but I don't know how that formats.
>> This is a questionable place, the {@code Strings} is not strictly correct,
>> but {@code String}s is looks odd as well, because part of the same word is rendered by the
>> different fonts in the javadoc.
>> Probably the best choice is to change the "Strings" to the
>> plain "strings"(lowcase S)? 

Best regards, Sergey.

More information about the awt-dev mailing list