<AWT Dev> RFR: 8254850: Update terminology in java.awt.GridBagLayout source code comments

Kevin Rushforth kcr at openjdk.java.net
Tue Dec 15 19:13:57 UTC 2020

On Tue, 15 Dec 2020 17:47:54 GMT, Phil Race <prr at openjdk.org> wrote:

> This is part of an effort in the JDK to replace archaic/non-inclusive words with more neutral terms.
> See JDK-8253315 for details.
> This updates a few comments in GridBagLayout to use the terms parent and child which are
> sufficiently descriptive and consistent with lots of other usages.

Looks good. One minor question.

src/java.desktop/share/classes/java/awt/GridBagLayout.java line 1367:

> 1365: 
> 1366:                         /*
> 1367:                          * Figure out if we should use this child\'s weight.  If the weight

Is the `` still needed?


Marked as reviewed by kcr (Author).

PR: https://git.openjdk.java.net/jdk/pull/1784

More information about the awt-dev mailing list