Patch to build 64 bit VM

Michael Franz mvfranz at
Mon Jan 5 16:44:20 PST 2009

On Mon, Jan 5, 2009 at 2:14 PM, Xiaobin Lu <Xiaobin.Lu at> wrote:

>  On 01/05/09 04:42, Michael Franz wrote:
> Greg,
> This is my output:
> Apple Inc version cctools-698.1~1, GNU assembler version 1.38
> I have been trying to build 64 bit by only passing in the LP64=1 .  I have
> not been able to get it to work, it gets pretty far.  I have to change some
> cast from int64_t to intprt_t to get as far as I do.
> This is what I did on my Leopard system. Go to the bsd-port directory and
> type "make ALT_BOOTDIR=/usr/local/soylatte-amd64-1.0.3 LP64=1 hotspot" and I
> can build the hotspot successfully. I also tried to go to make directory
> under hotspot subdirectory and type "make
> ALT_BOOTDIR=/usr/local/soylatte-amd64-1.0.3
> ALT_OUTPUTDIR=/export/bsd-port/build/bsd-port/hotspot/outputdir LP64=1 jvmg
> product fastdebug" and that will do the same thing.
> Once I put in the correct casts (change int32_t to intptr_t) the 32 bit
> build is fine.
> As I mentioned in another email, my fix for this has only been checked into
> hotspot-rt repository and hasn't been integrated to the hotspot repository.
> I assume that will happen by the end of this week or early next week.
> -Xiaobin

I tried the hotspot build for LP64 and get the same error as before:
-classpath bsd_amd64_docs jvmtiGen -IN
-OUT bsd_amd64_docs/jvmti.html
make VM_SUBDIR=product                            generic_export
make[2]: *** No rule to make target
needed by `generic_export'.  Stop.
make[1]: *** [export_product] Error 2
make: *** [hotspot-build] Error 2

I am not using Soylatte, but the openjdk binary.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the bsd-port-dev mailing list